<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
<!--<script data-cfasync='false' data-mrf-script="garda" data-mrf-dt="1" data-mrf-host="bc.marfeelcache.com" src="https://bc.marfeelcache.com/statics/marfeel/gardac-sync.js"></script>
-->    
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://www.bjpenn.com/xmlrpc.php" />
    <img src="https://ad.doubleclick.net/ddm/trackimp/N6344.3178460IMPACTRADIUS/B21938790.233268953;dc_trk_aid=430994783;dc_trk_cid=108425359;ord=[timestamp];dc_lat=;dc_rdid=;tag_for_child_directed_treatment=;tfua=?" BORDER="0" HEIGHT="1" WIDTH="1" ALT="Advertisement"> </img>
    <script src="https://api.pushnami.com/scripts/v1/push/5c323df5364ea94ff762e14b"></script>
    <link rel="manifest" href="/manifest.json">

    <meta property="og:image" content="https://www.bjpenn.com/wp-content/uploads/Ben-Askren-1.png" /><link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://www.bjpenn.com/wp-content/uploads/IOS_76x76.png"/><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://www.bjpenn.com/wp-content/uploads/IOS_120x120.png"/><link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://www.bjpenn.com/wp-content/uploads/IOS_152x152.png"/><link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://www.bjpenn.com/wp-content/uploads/IOS_114x114.png"/><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://www.bjpenn.com/wp-content/uploads/IOS_144x144.png"/>
<!-- This site is optimized with the Yoast SEO Premium plugin v11.6 - https://yoast.com/wordpress/plugins/seo/ -->
<title>Chael Sonnen praises Ben Askren for how he&#039;s handled UFC 239 KO loss | BJPenn.com</title>
<meta name="description" content="Chael Sonnen gives props to Ben Askren for the way he&#039;s handled his five-second KO loss to Jorge Masvidal. It&#039;s the fastest KO in UFC history."/>
<link rel="canonical" href="https://www.bjpenn.com/mma-news/ufc/chael-sonnen-praises-ben-askren-for-how-hes-handled-ufc-239-ko-loss/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Chael Sonnen praises Ben Askren for how he&#039;s handled UFC 239 KO loss | BJPenn.com" />
<meta property="og:description" content="Chael Sonnen gives props to Ben Askren for the way he&#039;s handled his five-second KO loss to Jorge Masvidal. It&#039;s the fastest KO in UFC history." />
<meta property="og:url" content="https://www.bjpenn.com/mma-news/ufc/chael-sonnen-praises-ben-askren-for-how-hes-handled-ufc-239-ko-loss/" />
<meta property="og:site_name" content="| BJPenn.com" />
<meta property="article:publisher" content="http://facebook.com/bjpenn" />
<meta property="article:section" content="UFC" />
<meta property="article:published_time" content="2019-07-12T19:41:35+00:00" />
<meta property="og:image" content="https://www.bjpenn.com/wp-content/uploads/Ben-Askren-1.png" />
<meta property="og:image:secure_url" content="https://www.bjpenn.com/wp-content/uploads/Ben-Askren-1.png" />
<meta property="og:image:width" content="696" />
<meta property="og:image:height" content="399" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Chael Sonnen gives props to Ben Askren for the way he&#039;s handled his five-second KO loss to Jorge Masvidal. It&#039;s the fastest KO in UFC history." />
<meta name="twitter:title" content="Chael Sonnen praises Ben Askren for how he&#039;s handled UFC 239 KO loss | BJPenn.com" />
<meta name="twitter:site" content="@bjpenndotcom" />
<meta name="twitter:image" content="https://www.bjpenn.com/wp-content/uploads/Ben-Askren-1.png" />
<meta name="twitter:creator" content="@bjpenndotcom" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.bjpenn.com/#website","url":"https://www.bjpenn.com/","name":"| BJPenn.com","potentialAction":{"@type":"SearchAction","target":"https://www.bjpenn.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.bjpenn.com/mma-news/ufc/chael-sonnen-praises-ben-askren-for-how-hes-handled-ufc-239-ko-loss/#primaryimage","url":"https://www.bjpenn.com/wp-content/uploads/Ben-Askren-1.png","width":696,"height":399,"caption":"Ben Askren"},{"@type":"WebPage","@id":"https://www.bjpenn.com/mma-news/ufc/chael-sonnen-praises-ben-askren-for-how-hes-handled-ufc-239-ko-loss/#webpage","url":"https://www.bjpenn.com/mma-news/ufc/chael-sonnen-praises-ben-askren-for-how-hes-handled-ufc-239-ko-loss/","inLanguage":"en-US","name":"Chael Sonnen praises Ben Askren for how he&#039;s handled UFC 239 KO loss | BJPenn.com","isPartOf":{"@id":"https://www.bjpenn.com/#website"},"primaryImageOfPage":{"@id":"https://www.bjpenn.com/mma-news/ufc/chael-sonnen-praises-ben-askren-for-how-hes-handled-ufc-239-ko-loss/#primaryimage"},"datePublished":"2019-07-12T19:41:35+00:00","dateModified":"2019-07-12T19:41:35+00:00","description":"Chael Sonnen gives props to Ben Askren for the way he's handled his five-second KO loss to Jorge Masvidal. It's the fastest KO in UFC history."},{"@type":"NewsArticle","@id":"https://www.bjpenn.com/mma-news/ufc/chael-sonnen-praises-ben-askren-for-how-hes-handled-ufc-239-ko-loss/#article","isPartOf":{"@id":"https://www.bjpenn.com/mma-news/ufc/chael-sonnen-praises-ben-askren-for-how-hes-handled-ufc-239-ko-loss/#webpage"},"author":{"@id":"https://www.bjpenn.com/#/schema/person/2d741da321eb572a88d2884eb32b4b7e"},"headline":"Chael Sonnen praises Ben Askren for how he&#8217;s handled UFC 239 KO loss","datePublished":"2019-07-12T19:41:35+00:00","dateModified":"2019-07-12T19:41:35+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.bjpenn.com/mma-news/ufc/chael-sonnen-praises-ben-askren-for-how-hes-handled-ufc-239-ko-loss/#webpage"},"image":{"@id":"https://www.bjpenn.com/mma-news/ufc/chael-sonnen-praises-ben-askren-for-how-hes-handled-ufc-239-ko-loss/#primaryimage"},"articleSection":"Ben Askren,Chael Sonnen,Jorge Masvidal,UFC","copyrightYear":"2019","copyrightHolder":{"@id":"https://www.bjpenn.com#organization"}},{"@type":["Person"],"@id":"https://www.bjpenn.com/#/schema/person/2d741da321eb572a88d2884eb32b4b7e","name":"Fernando Quiles","image":{"@type":"ImageObject","@id":"https://www.bjpenn.com/#authorlogo","url":"https://secure.gravatar.com/avatar/d52c2bb4703974deefb8dec31ccdacb1?s=96&d=mm&r=r","caption":"Fernando Quiles"},"sameAs":[]}]}</script>
<!-- / Yoast SEO Premium plugin. -->

<link rel='dns-prefetch' href='//www.bjpenn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="| BJPenn.com &raquo; Feed" href="https://www.bjpenn.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="| BJPenn.com &raquo; Comments Feed" href="https://www.bjpenn.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="| BJPenn.com &raquo; Chael Sonnen praises Ben Askren for how he&#8217;s handled UFC 239 KO loss Comments Feed" href="https://www.bjpenn.com/mma-news/ufc/chael-sonnen-praises-ben-askren-for-how-hes-handled-ufc-239-ko-loss/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.bjpenn.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.2"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.bjpenn.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='main_stylesheet-css'  href='https://www.bjpenn.com/wp-content/plugins/spotim-comments/assets/stylesheets/main.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900&#038;ver=9.1' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='https://www.bjpenn.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=4.12.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://www.bjpenn.com/wp-content/themes/Newspaper/style.css?ver=9.1' type='text/css' media='all' />
<script type='text/javascript' src='https://www.bjpenn.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.bjpenn.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://www.bjpenn.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.bjpenn.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.bjpenn.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.2.2" />
<link rel='shortlink' href='https://www.bjpenn.com/?p=319255' />
<link rel="alternate" type="application/json+oembed" href="https://www.bjpenn.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.bjpenn.com%2Fmma-news%2Fufc%2Fchael-sonnen-praises-ben-askren-for-how-hes-handled-ufc-239-ko-loss%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.bjpenn.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.bjpenn.com%2Fmma-news%2Fufc%2Fchael-sonnen-praises-ben-askren-for-how-hes-handled-ufc-239-ko-loss%2F&#038;format=xml" />
<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
    <meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://www.bjpenn.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="https://www.bjpenn.com/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]--><link rel="amphtml" href="https://www.bjpenn.com/mma-news/ufc/chael-sonnen-praises-ben-askren-for-how-hes-handled-ufc-239-ko-loss/amp/">
<!-- JS generated by theme -->

<script>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</script>

<script>
var pubg = pubg || {};
pubg.queue = pubg.queue || [];

headerBidderScript = document.createElement('script');
headerBidderScript.async = 'async';
headerBidderScript.src = "https://delivery.pubgenius.io/www.bjpe-1C1zSru0.js";
document.head.appendChild(headerBidderScript);
</script><script type="application/ld+json">
                        {
                            "@context": "http://schema.org",
                            "@type": "BreadcrumbList",
                            "itemListElement": [{
                            "@type": "ListItem",
                            "position": 1,
                                "item": {
                                "@type": "WebSite",
                                "@id": "https://www.bjpenn.com/",
                                "name": "Home"                                               
                            }
                        },{
                            "@type": "ListItem",
                            "position": 2,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://www.bjpenn.com/mma-news/",
                                "name": "MMA News"
                            }
                        },{
                            "@type": "ListItem",
                            "position": 3,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://www.bjpenn.com/mma-news/ben-askren/",
                                "name": "Ben Askren"                                
                            }
                        },{
                            "@type": "ListItem",
                            "position": 4,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://www.bjpenn.com/mma-news/ufc/chael-sonnen-praises-ben-askren-for-how-hes-handled-ufc-239-ko-loss/",
                                "name": "Chael Sonnen praises Ben Askren for how he&#8217;s handled UFC 239 KO..."                                
                            }
                        }    ]
                        }
                       </script><link rel="icon" href="https://www.bjpenn.com/wp-content/uploads/cropped-faviconbjp-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.bjpenn.com/wp-content/uploads/cropped-faviconbjp-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.bjpenn.com/wp-content/uploads/cropped-faviconbjp-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.bjpenn.com/wp-content/uploads/cropped-faviconbjp-270x270.png" />

<!-- BEGIN ExactMetrics v5.3.8 Universal Analytics - https://exactmetrics.com/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-1429346-1', 'auto');
  ga('set', 'dimension1', 'Fernando Quiles');
  ga('send', 'pageview');
</script>
<!-- END ExactMetrics Universal Analytics -->
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>    
	<!-- Header Tag Code --><!--<script data-cfasync='false' type='text/javascript'>/*<![CDATA[*/(function (a, c, s, u){'Insticator'in a || (a.Insticator={ad:{loadAd: function (b){Insticator.ad.q.push(b)}, q: []}, helper:{}, embed:{}, version: "3.0", q: [], load: function (t, o){Insticator.q.push({t: t, o: o})}}); var b=c.createElement(s); b.src=u; b.async=!0; var d=c.getElementsByTagName(s)[0]; d.parentNode.insertBefore(b, d)})(window, document, 'script', '//d2na2p72vtqyok.cloudfront.net/client-embed/b3b45807-1f67-4bcc-8b01-74a1be7de48e.js');/*]]>*/</script>--><!-- End Header Tag Code -->
    
</head>

<body class="post-template-default single single-post postid-319255 single-format-standard chael-sonnen-praises-ben-askren-for-how-hes-handled-ufc-239-ko-loss global-block-template-11 wpb-js-composer js-comp-ver-4.12.1 vc_responsive td-animation-stack-type0 td-boxed-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">
        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/bjpenn/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/bjpenn/" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/bjpenndotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/bjpenndotcom" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-270896" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-first menu-item-270896"><a href="https://www.bjpenn.com/mma-news/">MMA News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-287665" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-287665"><a href="https://www.bjpenn.com/ufc/">UFC</a></li>
	<li id="menu-item-286236" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-286236"><a href="https://www.bjpenn.com/one-championship/">ONE Championship</a></li>
	<li id="menu-item-290324" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-290324"><a href="https://www.bjpenn.com/rizin-ff/">RIZIN FF</a></li>
	<li id="menu-item-288011" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-288011"><a href="https://www.bjpenn.com/bellator/">Bellator</a></li>
</ul>
</li>
<li id="menu-item-270897" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-270897"><a href="https://www.bjpenn.com/mma-news/videos/">Videos</a></li>
<li id="menu-item-270899" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-270899"><a href="https://www.bjpenn.com/mma-news/exclusive-interviews/">Exclusives</a></li>
<li id="menu-item-288033" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-288033"><a href="https://www.bjpenn.com/mma-news/podcasts/">RADIO</a></li>
<li id="menu-item-270900" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-270900"><a href="#">Tutorials<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-271962" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-271962"><a href="https://www.bjpenn.com/tutorials/bjj-with-bj/">BJJ with BJ</a></li>
	<li id="menu-item-271589" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-271589"><a href="https://www.bjpenn.com/tutorials/dr-pete/">Dr. Pete</a></li>
	<li id="menu-item-270901" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-270901"><a href="https://www.bjpenn.com/tutorials/bjj/">BJJ</a></li>
	<li id="menu-item-270902" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-270902"><a href="https://www.bjpenn.com/tutorials/muay-thai/">Muay Thai</a></li>
	<li id="menu-item-270903" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-270903"><a href="https://www.bjpenn.com/tutorials/grappling/">Grappling</a></li>
	<li id="menu-item-270904" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-270904"><a href="https://www.bjpenn.com/tutorials/tai-chi/">Tai Chi</a></li>
	<li id="menu-item-270905" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-270905"><a href="https://www.bjpenn.com/tutorials/wrestling/">Wrestling</a></li>
</ul>
</li>
<li id="menu-item-270906" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-270906"><a href="#">Fighters<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-270907" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-270907"><a href="https://www.bjpenn.com/fighter/cris-cyborg/">Cris Cyborg</a></li>
	<li id="menu-item-270908" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-270908"><a href="https://www.bjpenn.com/fighter/nate-diaz/">Nate Diaz</a></li>
	<li id="menu-item-271562" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-271562"><a href="https://www.bjpenn.com/fighter/ronda-rousey/">Ronda Rousey</a></li>
	<li id="menu-item-271563" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-271563"><a href="https://www.bjpenn.com/fighter/frankie-edgar/">Frankie Edgar</a></li>
	<li id="menu-item-270909" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-270909"><a href="https://www.bjpenn.com/fighter/georges-st-pierre/">Georges St. Pierre</a></li>
	<li id="menu-item-270911" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-270911"><a href="https://www.bjpenn.com/fighter/jorge-masvidal/">Jorge Masvidal</a></li>
	<li id="menu-item-270910" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-270910"><a href="https://www.bjpenn.com/fighter/conor-mcgregor/">Conor McGregor</a></li>
</ul>
</li>
<li id="menu-item-168252" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-168252"><a href="http://penngym.com">Gym</a></li>
<li id="menu-item-168253" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-168253"><a href="http://shop.bjpenn.com">Shop</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="https://www.bjpenn.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap" class="td-theme-wrap">
    
        <!--
Header style 12
-->


<div class="td-header-wrap td-header-style-12 ">
    
	<div class="td-header-menu-wrap-full td-container-wrap ">
        
        <div class="td-header-menu-wrap td-header-gradient ">
			<div class="td-container td-header-row td-header-main-menu">
				<div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-menu">
        		<a class="td-mobile-logo td-sticky-header" href="https://www.bjpenn.com/">
			<img class="td-retina-data" data-retina="https://www.bjpenn.com/wp-content/uploads/black-mobile_retna.png" src="https://www.bjpenn.com/wp-content/uploads/black-mobile.png" alt="bj penn logo" title="BJPENN.COM"/>
		</a>
			<a class="td-header-logo td-sticky-header" href="https://www.bjpenn.com/">
			<img class="td-retina-data" data-retina="https://www.bjpenn.com/wp-content/uploads/bj-p-logo_retna_.png" src="https://www.bjpenn.com/wp-content/uploads/bjplogo.png" alt="bj penn logo" title="BJPENN.COM"/>
			<span class="td-visual-hidden">| BJPenn.com</span>
		</a>
	    </div>
    <div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-first td-menu-item td-normal-menu menu-item-270896"><a href="https://www.bjpenn.com/mma-news/">MMA News</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-287665"><a href="https://www.bjpenn.com/ufc/">UFC</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-286236"><a href="https://www.bjpenn.com/one-championship/">ONE Championship</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-290324"><a href="https://www.bjpenn.com/rizin-ff/">RIZIN FF</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-288011"><a href="https://www.bjpenn.com/bellator/">Bellator</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-270897"><a href="https://www.bjpenn.com/mma-news/videos/">Videos</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-270899"><a href="https://www.bjpenn.com/mma-news/exclusive-interviews/">Exclusives</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-288033"><a href="https://www.bjpenn.com/mma-news/podcasts/">RADIO</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-270900"><a href="#">Tutorials</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-271962"><a href="https://www.bjpenn.com/tutorials/bjj-with-bj/">BJJ with BJ</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-271589"><a href="https://www.bjpenn.com/tutorials/dr-pete/">Dr. Pete</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-270901"><a href="https://www.bjpenn.com/tutorials/bjj/">BJJ</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-270902"><a href="https://www.bjpenn.com/tutorials/muay-thai/">Muay Thai</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-270903"><a href="https://www.bjpenn.com/tutorials/grappling/">Grappling</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-270904"><a href="https://www.bjpenn.com/tutorials/tai-chi/">Tai Chi</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-270905"><a href="https://www.bjpenn.com/tutorials/wrestling/">Wrestling</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-270906"><a href="#">Fighters</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-270907"><a href="https://www.bjpenn.com/fighter/cris-cyborg/">Cris Cyborg</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-270908"><a href="https://www.bjpenn.com/fighter/nate-diaz/">Nate Diaz</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-271562"><a href="https://www.bjpenn.com/fighter/ronda-rousey/">Ronda Rousey</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-271563"><a href="https://www.bjpenn.com/fighter/frankie-edgar/">Frankie Edgar</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-270909"><a href="https://www.bjpenn.com/fighter/georges-st-pierre/">Georges St. Pierre</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-270911"><a href="https://www.bjpenn.com/fighter/jorge-masvidal/">Jorge Masvidal</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-270910"><a href="https://www.bjpenn.com/fighter/conor-mcgregor/">Conor McGregor</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-168252"><a href="http://penngym.com">Gym</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-168253"><a href="http://shop.bjpenn.com">Shop</a></li>
</ul></div></div>


    <div class="header-search-wrap">
        <div class="td-search-btns-wrap">
            <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
        </div>

        <div class="td-drop-down-search" aria-labelledby="td-header-search-button">
            <form method="get" class="td-search-form" action="https://www.bjpenn.com/">
                <div role="search" class="td-head-form-search-wrap">
                    <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
                </div>
            </form>
            <div id="td-aj-search"></div>
        </div>
    </div>
			</div>
		</div>
	</div>

	<div class="td-header-top-menu-full td-container-wrap ">
		<div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div >

                Friday, July 12, 2019
            </div>
        </div>
    </div>
        <div class="td-header-sp-top-widget">
    
    
        
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/bjpenn/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/bjpenn/" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/bjpenndotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/bjpenndotcom" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span>    </div>    </div>

<!-- LOGIN MODAL -->
		</div>
	</div>

            <div class="td-header-header-full td-banner-wrap-full td-container-wrap ">
            <div class="td-container-header td-header-row td-header-header">
                <div class="td-header-sp-recs">
                    <div class="td-header-rec-wrap">
    <div class="td-a-rec td-a-rec-id-header  td_uid_1_5d28f095452ac_rand td_block_template_11"><div class="td-all-devices">
  <div id='pubg-U24-6Ty'>
  <script>pubg.queue.push(function(){initAdUnit("pubg-U24-6Ty");});</script>
  </div>

  <div id='pubg-rA5-3bG' style="padding-top: 16px;">
  <script>pubg.queue.push(function(){initAdUnit("pubg-rA5-3bG");});</script>
  </div>
</div></div>
</div>                </div>
            </div>
        </div>
    </div><div class="td-main-content-wrap td-container-wrap">

    <div class="td-container td-post-template-default ">
        <div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://www.bjpenn.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in MMA News" class="entry-crumb" href="https://www.bjpenn.com/mma-news/">MMA News</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Ben Askren" class="entry-crumb" href="https://www.bjpenn.com/mma-news/ben-askren/">Ben Askren</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Chael Sonnen praises Ben Askren for how he&#8217;s handled UFC 239 KO...</span></div></div>

        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-319255" class="post-319255 post type-post status-publish format-standard has-post-thumbnail hentry category-ben-askren category-chael-sonnen category-jorge-masvidal category-ufc" itemscope itemtype="https://schema.org/Article">
        <div class="td-post-header">

            
            <header class="td-post-title">
                <h1 class="entry-title">Chael Sonnen praises Ben Askren for how he&#8217;s handled UFC 239 KO loss</h1>

                

                <div class="td-module-meta-info">

                    <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://www.bjpenn.com/author/fernando-quiles-jr/">Fernando Quiles</a><div class="td-author-line"> - </div> </div>                    <span class="td-post-date td-post-date-no-dot"><time class="entry-date updated td-module-date" datetime="2019-07-12T12:41:35+00:00" >July 12, 2019</time></span>                                                        </div>

            </header>

        </div>

        <div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.bjpenn.com%2Fmma-news%2Fufc%2Fchael-sonnen-praises-ben-askren-for-how-hes-handled-ufc-239-ko-loss%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Chael+Sonnen+praises+Ben+Askren+for+how+he%E2%80%99s+handled+UFC+239+KO+loss&url=https%3A%2F%2Fwww.bjpenn.com%2Fmma-news%2Fufc%2Fchael-sonnen-praises-ben-askren-for-how-hes-handled-ufc-239-ko-loss%2F&via=bjpenndotcom">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="mailto:?subject=Chael Sonnen praises Ben Askren for how he&#8217;s handled UFC 239 KO loss&body=https://www.bjpenn.com/mma-news/ufc/chael-sonnen-praises-ben-askren-for-how-hes-handled-ufc-239-ko-loss/">
                                        <div class="td-social-but-icon"><i class="td-icon-mail"></i></div>
                                        <div class="td-social-but-text">Email</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://www.bjpenn.com/mma-news/ufc/chael-sonnen-praises-ben-askren-for-how-hes-handled-ufc-239-ko-loss/&title=Chael Sonnen praises Ben Askren for how he&#8217;s handled UFC 239 KO loss">
                                        <div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
                                        <div class="td-social-but-text">ReddIt</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>

        <div class="td-post-content">

        <div class="td-post-featured-image"><figure><img width="696" height="399" class="entry-thumb" src="https://www.bjpenn.com/wp-content/uploads/Ben-Askren-1-696x399.png" srcset="https://www.bjpenn.com/wp-content/uploads/Ben-Askren-1.png 696w, https://www.bjpenn.com/wp-content/uploads/Ben-Askren-1-300x172.png 300w" sizes="(max-width: 696px) 100vw, 696px" alt="Ben Askren" title="Ben Askren"/><figcaption class="wp-caption-text">Image: @ufc on Instagram</figcaption></figure></div>        <p>Chael Sonnen is impressed with the way Ben Askren has faced the music.</p>
<p>Askren entered the UFC with substantial hype. He was part of the UFC&#8217;s trade with ONE Championship. In exchange for Demetrious Johnson, Askren was sent over to the most recognized mixed martial arts promotion. &#8220;Funky&#8221; had a successful, albeit controversial, debut against Robbie Lawler back in March. He submitted Lawler in the first round. In his second UFC bout, Askren was flattened in a record-setting five seconds via <a href="https://www.bjpenn.com/mma-news/ufc/ufc-239-results-jorge-masvidal-kos-ben-askren-video/" target="_blank" rel="noopener noreferrer">flying knee</a> courtesy of Jorge Masvidal.</p>
<p>Retired mixed martial artist Sonnen took to his <a href="https://www.youtube.com/watch?v=WydWf6RHNOM" target="_blank" rel="noopener noreferrer">YouTube channel</a> to post a video giving his take on why fans are more accepting of Ben Askren following such a devastating loss:</p><div class='code-block code-block-8' style='margin: 8px 0; clear: both;'>
  <div class='s2nPlayer k-iY5k6dpk' data-type='float'></div>
  <script type='text/javascript' src='//embed.sendtonews.com/player3/embedcode.js?fk=iY5k6dpk&cid=9090&offsetx=0&offsety=0&floatwidth=400&floatposition=bottom-right' data-type='s2nScript'></script>
</div>

<p><iframe title="Ben Askren taught us how to lose..." width="696" height="392" src="https://www.youtube.com/embed/WydWf6RHNOM?feature=oembed" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
<p>&#8220;I believe it&#8217;s because people are seeing the real Ben Askren, which is a guy who likes to go out and entertain,&#8221; Sonnen said. &#8220;He likes to antagonize because he understands the business and he understands to get his spot and make sure he has attention, he needs to do a little of that. A guy who makes weight, walks out there, does the heavy lifting, takes on anybody that&#8217;s asked of him under any ruleset in any continent in any organization you want to do it in. And then tips his hat at the end of the night likes a sportsman would. No excuses, tip your hat, grab your stuff, shower up and move on.&#8221;</p>
<p>Askren <a href="https://www.bjpenn.com/mma-news/ufc/ben-askren-opens-up-on-5-second-ko-loss-to-jorge-masvidal/" target="_blank" rel="noopener noreferrer">owned up to his loss</a> just two days after being knocked out. He joked about setting a record and gave Masvidal props for pulling off the victory in spectacular fashion.</p>
<p class="p1">“I always thought, ‘who the hell gets flying kneed? Can’t you see that coming? It’s coming from so far away!’ When I watched the film — I don’t like Jorge at all — but that was a damn good flying knee,” Askren said on Ariel Helwani&#8217;s MMA Show. “He hit it fast and explosively, he got some serious air time on it, and then obviously connected in the right spot.”</p>
<p>Do you think Ben Askren will rebound from his record-setting KO loss to Jorge Masvidal?</p>
<p class="p1"><i>This article first appeared on </i><a href="https://www.bjpenn.com/"><span class="s1"><i>BJPENN.COM</i></span></a><i> on 7/12/2019. </i></p>
<div data-spotim-module="recirculation" data-spot-id="sp_8vU9rdi6"></div>
<script async src="https://recirculation.spot.im/spot/sp_8vU9rdi6" data-spotim-script="recirculation"></script> 
<div id="comments-anchor" class="spot-im-comments comments-area">
        <script async
            data-spotim-module="spotim-launcher"
            data-article-tags=""
            src="https://launcher.spot.im/spot/sp_8vU9rdi6"
            data-post-id="319255"
            data-post-url="https://www.bjpenn.com/mma-news/ufc/chael-sonnen-praises-ben-askren-for-how-hes-handled-ufc-239-ko-loss/"
            data-short-url="https://www.bjpenn.com/?p=319255"
            data-messages-count="10"
            data-wp-import-endpoint="https://www.bjpenn.com/mma-news/ufc/chael-sonnen-praises-ben-askren-for-how-hes-handled-ufc-239-ko-loss/feed/spotim/"
            data-facebook-url="https://www.bjpenn.com/mma-news/ufc/chael-sonnen-praises-ben-askren-for-how-hes-handled-ufc-239-ko-loss/"
            data-disqus-shortname=""
            data-disqus-url="https://www.bjpenn.com/mma-news/ufc/chael-sonnen-praises-ben-askren-for-how-hes-handled-ufc-239-ko-loss/"
            data-disqus-identifier="319255 https://www.bjpenn.com/?p=319255"
            data-community-question=""
            data-seo-enabled="false"
            data-wp-v="p-4.5.0/wp-5.2.2"
    ></script>
    </div>
<div class="td-a-rec td-a-rec-id-content_bottom  td_uid_2_5d28f09547f9b_rand td_block_template_11"><div class="td-all-devices">
  <div id='pubg-NAt-P81'>
  <script>pubg.queue.push(function(){initAdUnit("pubg-NAt-P81");});</script>
  </div>

  <div id='pubg-dma-xpu'>
  <script>pubg.queue.push(function(){initAdUnit("pubg-dma-xpu");});</script>
  </div>
</div>
</div>        </div>
<!--						<div id="disqus_thread"></div>
--><!--<script>
    /**
     *  RECOMMENDED CONFIGURATION VARIABLES: EDIT AND UNCOMMENT THE SECTION BELOW TO INSERT DYNAMIC VALUES FROM YOUR PLATFORM OR CMS.
     *  LEARN WHY DEFINING THESE VARIABLES IS IMPORTANT: https://disqus.com/admin/universalcode/#configuration-variables
     */
    /*
    var disqus_config = function () {
        this.page.url = PAGE_URL;  // Replace PAGE_URL with your page's canonical URL variable
        this.page.identifier = PAGE_IDENTIFIER; // Replace PAGE_IDENTIFIER with your page's unique identifier variable
    };
    */
    (function() {  // DON'T EDIT BELOW THIS LINE
        var d = document, s = d.createElement('script');
        
        s.src = 'https://bjpenndotcom.disqus.com/embed.js';
        
        s.setAttribute('data-timestamp', +new Date());
        (d.head || d.body).appendChild(s);
    })();
</script>
<noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript" rel="nofollow">comments powered by Disqus.</a></noscript>-->


<!--<div id="rcjsload_a122d7"></div>
				<script src="https://labs-cdn.revcontent.com/build/revmore-standard.min.js"></script>
				<script type="text/javascript">
				var devices = [/*'phone', 'tablet'*/];
				var empty = revDetect.show(devices);
				(function() {
				var referer="";try{if(referer=document.referrer,"undefined"==typeof referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700);
				var rcel = document.createElement("script");
				rcel.id = 'rc_' + Math.floor(Math.random() * 1000);
				rcel.type = 'text/javascript';
				rcel.src = "//trends.revcontent.com/serve.js.php?"+ (empty ? "empty=1&" : "") +"w=85251&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth || document.documentElement.clientWidth)+"&referer="+referer;
				rcel.async = true;
				var rcds = document.getElementById("rcjsload_a122d7"); rcds.appendChild(rcel);
				var more = new RevMore({
				top_id: 'top-id',

				widget_id : 85251,

				devices: devices,

				unlock_text: 'Read More'
				});
				})();
				</script>
-->

        <footer>
                        
            <div class="td-post-source-tags">
                                            </div>

                                   	        <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Fernando Quiles"></span><meta itemprop="datePublished" content="2019-07-12T12:41:35+00:00"><meta itemprop="dateModified" content="2019-07-12T12:41:35-07:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.bjpenn.com/mma-news/ufc/chael-sonnen-praises-ben-askren-for-how-hes-handled-ufc-239-ko-loss/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.bjpenn.com/wp-content/uploads/bjplogo.png"></span><meta itemprop="name" content="| BJPenn.com"></span><meta itemprop="headline " content="Chael Sonnen praises Ben Askren for how he&#039;s handled UFC 239 KO loss"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.bjpenn.com/wp-content/uploads/Ben-Askren-1.png"><meta itemprop="width" content="696"><meta itemprop="height" content="399"></span>        </footer>

    </article> <!-- /.post -->

    <div class="td_block_wrap td_block_related_posts td_uid_3_5d28f0954838b_rand td_with_ajax_pagination td-pb-border-top td_block_template_11"  data-td-block-uid="td_uid_3_5d28f0954838b" ><script>var block_td_uid_3_5d28f0954838b = new tdBlock();
block_td_uid_3_5d28f0954838b.id = "td_uid_3_5d28f0954838b";
block_td_uid_3_5d28f0954838b.atts = '{"limit":6,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"td_uid_3_5d28f0954838b_rand","td_column_number":3,"live_filter_cur_post_id":319255,"live_filter_cur_post_author":"54476","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"td_uid_3_5d28f0954838b_rand","tdc_css_class_style":"td_uid_3_5d28f0954838b_rand_style"}';
block_td_uid_3_5d28f0954838b.td_column_number = "3";
block_td_uid_3_5d28f0954838b.block_type = "td_block_related_posts";
block_td_uid_3_5d28f0954838b.post_count = "6";
block_td_uid_3_5d28f0954838b.found_posts = "3691";
block_td_uid_3_5d28f0954838b.header_color = "";
block_td_uid_3_5d28f0954838b.ajax_pagination_infinite_stop = "";
block_td_uid_3_5d28f0954838b.max_num_pages = "616";
tdBlocksArray.push(block_td_uid_3_5d28f0954838b);
</script><h4 class="td-related-title td-block-title"><a id="td_uid_4_5d28f0954d890" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_3_5d28f0954838b" href="#">RELATED ARTICLES</a><a id="td_uid_5_5d28f0954d8d5" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_3_5d28f0954838b" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_3_5d28f0954838b class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.bjpenn.com/mma-news/ufc/anthony-smith-goes-off-on-light-heavyweight-rival-corey-anderson/" rel="bookmark" class="td-image-wrap" title="Anthony Smith goes off on light heavyweight rival Corey Anderson"><img width="218" height="150" class="entry-thumb" src="https://www.bjpenn.com/wp-content/uploads/Corey-Anderson-Anthony-Smith-218x150.jpg" srcset="https://www.bjpenn.com/wp-content/uploads/Corey-Anderson-Anthony-Smith-218x150.jpg 218w, https://www.bjpenn.com/wp-content/uploads/Corey-Anderson-Anthony-Smith-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Corey Anderson, Anthony Smith" title="Anthony Smith goes off on light heavyweight rival Corey Anderson"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.bjpenn.com/mma-news/ufc/anthony-smith-goes-off-on-light-heavyweight-rival-corey-anderson/" rel="bookmark" title="Anthony Smith goes off on light heavyweight rival Corey Anderson">Anthony Smith goes off on light heavyweight rival Corey Anderson</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.bjpenn.com/mma-news/ufc/chad-mendes-reminisces-on-fight-with-conor-mcgregor/" rel="bookmark" class="td-image-wrap" title="Chad Mendes reminisces on fight with Conor McGregor"><img width="218" height="150" class="entry-thumb" src="https://www.bjpenn.com/wp-content/uploads/Conor-McGregor-Chad-Mendes-218x150.png" srcset="https://www.bjpenn.com/wp-content/uploads/Conor-McGregor-Chad-Mendes-218x150.png 218w, https://www.bjpenn.com/wp-content/uploads/Conor-McGregor-Chad-Mendes-100x70.png 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Conor McGregor, Chad Mendes" title="Chad Mendes reminisces on fight with Conor McGregor"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.bjpenn.com/mma-news/ufc/chad-mendes-reminisces-on-fight-with-conor-mcgregor/" rel="bookmark" title="Chad Mendes reminisces on fight with Conor McGregor">Chad Mendes reminisces on fight with Conor McGregor</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.bjpenn.com/mma-news/ufc/betting-odds-released-for-potential-conor-mcgregor-vs-jorge-masvidal-fight/" rel="bookmark" class="td-image-wrap" title="Betting odds released for potential Conor McGregor vs. Jorge Masvidal fight"><img width="218" height="150" class="entry-thumb" src="https://www.bjpenn.com/wp-content/uploads/Jorge-Masvidal-Conor-McGregor-218x150.jpg" srcset="https://www.bjpenn.com/wp-content/uploads/Jorge-Masvidal-Conor-McGregor-218x150.jpg 218w, https://www.bjpenn.com/wp-content/uploads/Jorge-Masvidal-Conor-McGregor-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Jorge Masvidal, Conor McGregor" title="Betting odds released for potential Conor McGregor vs. Jorge Masvidal fight"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.bjpenn.com/mma-news/ufc/betting-odds-released-for-potential-conor-mcgregor-vs-jorge-masvidal-fight/" rel="bookmark" title="Betting odds released for potential Conor McGregor vs. Jorge Masvidal fight">Betting odds released for potential Conor McGregor vs. Jorge Masvidal fight</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid-->

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.bjpenn.com/mma-news/ufc/anderson-silva-says-his-son-will-be-a-better-fighter-than-him/" rel="bookmark" class="td-image-wrap" title="Anderson Silva says his son will be a better fighter than him"><img width="218" height="150" class="entry-thumb" src="https://www.bjpenn.com/wp-content/uploads/Anderson-Silva-218x150.jpg" srcset="https://www.bjpenn.com/wp-content/uploads/Anderson-Silva-218x150.jpg 218w, https://www.bjpenn.com/wp-content/uploads/Anderson-Silva-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Anderson Silva" title="Anderson Silva says his son will be a better fighter than him"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.bjpenn.com/mma-news/ufc/anderson-silva-says-his-son-will-be-a-better-fighter-than-him/" rel="bookmark" title="Anderson Silva says his son will be a better fighter than him">Anderson Silva says his son will be a better fighter than him</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.bjpenn.com/mma-news/ufc/coach-holly-holm-will-recover-from-head-kick-ko-unlike-ronda-rousey/" rel="bookmark" class="td-image-wrap" title="Coach: Holly Holm will recover from head kick KO, unlike Ronda Rousey"><img width="218" height="150" class="entry-thumb" src="https://www.bjpenn.com/wp-content/uploads/Holly-Holm-218x150.png" srcset="https://www.bjpenn.com/wp-content/uploads/Holly-Holm-218x150.png 218w, https://www.bjpenn.com/wp-content/uploads/Holly-Holm-100x70.png 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Holly Holm" title="Coach: Holly Holm will recover from head kick KO, unlike Ronda Rousey"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.bjpenn.com/mma-news/ufc/coach-holly-holm-will-recover-from-head-kick-ko-unlike-ronda-rousey/" rel="bookmark" title="Coach: Holly Holm will recover from head kick KO, unlike Ronda Rousey">Coach: Holly Holm will recover from head kick KO, unlike Ronda Rousey</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.bjpenn.com/mma-news/ufc/joe-rogan-pokes-fun-at-diego-sanchezs-self-awareness-coach/" rel="bookmark" class="td-image-wrap" title="Joe Rogan pokes fun at Diego Sanchez&#8217;s &#8216;self-awareness coach&#8217;"><img width="218" height="150" class="entry-thumb" src="https://www.bjpenn.com/wp-content/uploads/Joe-Rogan-Diego-Sanchez-218x150.jpg" srcset="https://www.bjpenn.com/wp-content/uploads/Joe-Rogan-Diego-Sanchez-218x150.jpg 218w, https://www.bjpenn.com/wp-content/uploads/Joe-Rogan-Diego-Sanchez-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Joe Rogan, Diego Sanchez" title="Joe Rogan pokes fun at Diego Sanchez&#8217;s &#8216;self-awareness coach&#8217;"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.bjpenn.com/mma-news/ufc/joe-rogan-pokes-fun-at-diego-sanchezs-self-awareness-coach/" rel="bookmark" title="Joe Rogan pokes fun at Diego Sanchez&#8217;s &#8216;self-awareness coach&#8217;">Joe Rogan pokes fun at Diego Sanchez&#8217;s &#8216;self-awareness coach&#8217;</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_5d28f0954838b" data-td_block_id="td_uid_3_5d28f0954838b"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_3_5d28f0954838b" data-td_block_id="td_uid_3_5d28f0954838b"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->
                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <div class="td-a-rec td-a-rec-id-sidebar  td_uid_6_5d28f095502ab_rand td_block_template_11"><div class="td-all-devices">
  <!-- First sidebar ad -->
<div id='pubg-qpe-tVa'>
<script>pubg.queue.push(function(){initAdUnit("pubg-qpe-tVa");});</script>
</div>

<div id='pubg-crD-BsZ'>
<script>pubg.queue.push(function(){initAdUnit("pubg-crD-BsZ");});</script>
</div>
</div>
</div><aside class="td_block_template_11 widget widget_media_image"><a href="http://espn.zlbu.net/c/1359581/566400/9070" target="_blank" rel="noopener noreferrer"><img width="300" height="250" src="https://www.bjpenn.com/wp-content/uploads/espnplus_ufc_default.jpeg" class="image wp-image-303572  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" /></a></aside><div class="td-a-rec td-a-rec-id-custom_ad_1  td_uid_7_5d28f0955093d_rand td_block_template_11"><div class="td-all-devices">
<!-- Second ad in sidebar -->
  <div id='pubg-OFO-VcR'>
  <script>pubg.queue.push(function(){initAdUnit("pubg-OFO-VcR");});</script>
  </div>

  <div id='pubg-FQY-du4'>
  <script>pubg.queue.push(function(){initAdUnit("pubg-FQY-du4");});</script>
  </div>
</div></div><div class="td-a-rec td-a-rec-id-custom_ad_3  td_uid_8_5d28f09550b23_rand td_block_template_11"><!-- Insticator API Fire Widget--><!--<div id="insticator-container"><div id="div-insticator-ad-1"></div><div id="insticator-embed"></div><div id="div-insticator-ad-2"></div><script data-cfasync='false' type="text/javascript">/*<![CDATA[*/Insticator.ad.loadAd("div-insticator-ad-1");Insticator.ad.loadAd("div-insticator-ad-2");Insticator.load("em",{id : "cb97d8b6-68c0-48dc-bafa-31b1e4fcd1ed"})/*]]>*/</script></div>--><!--End Insticator API Fire Widget -->
<script type="text/javascript">
(function(){
             var au='/21678025661/bjpenn.com/300x600_inplace_slider',sz=[300,600],dv='div-gpt-ad-1537822820353-0';
             var dfpjs=document.createElement('script'),thjs=document.createElement('script');
             dfpjs.async=1;dfpjs.src='https://www.googletagservices.com/tag/js/gpt.js'; var taphypeSlot=null;
             thjs.innerHTML = "var googletag = googletag || {};googletag.cmd = googletag.cmd || [];pubg.queue.push(function () {googletag.cmd.push(function() {taphypeSlot=googletag.defineSlot('"+au+"', ["+sz.join(',')+"], '"+dv+"').addService(googletag.pubads());});});";
             document.head.appendChild(dfpjs); document.head.appendChild(thjs);
             document.write("<div id='"+dv+"' style='height:"+sz[1]+"px; width:"+sz[0]+"px;'><scr"+"ipt>pubg.queue.push(function (){ googletag.cmd.push(function() { googletag.display('"+dv+"'); googletag.pubads().refresh([taphypeSlot]);}); });</scr"+"ipt></div>");
           })();
    </script></div><div class="td_block_wrap td_block_7 td_block_widget td_uid_9_5d28f09550dae_rand td_with_ajax_pagination td-pb-border-top td_block_template_11 td-column-1 td_block_padding"  data-td-block-uid="td_uid_9_5d28f09550dae" ><script>var block_td_uid_9_5d28f09550dae = new tdBlock();
block_td_uid_9_5d28f09550dae.id = "td_uid_9_5d28f09550dae";
block_td_uid_9_5d28f09550dae.atts = '{"custom_title":"Latest News","custom_url":"","block_template_id":"","header_text_color":"#","border_color":"#","accent_text_color":"#","m6_tl":"","limit":"6","offset":"","el_class":"","post_ids":"","category_id":"","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"load_more","ajax_pagination_infinite_stop":"","class":"td_block_widget td_uid_9_5d28f09550dae_rand","separator":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","css":"","tdc_css":"","td_column_number":1,"header_color":"","color_preset":"","border_top":"","tdc_css_class":"td_uid_9_5d28f09550dae_rand","tdc_css_class_style":"td_uid_9_5d28f09550dae_rand_style"}';
block_td_uid_9_5d28f09550dae.td_column_number = "1";
block_td_uid_9_5d28f09550dae.block_type = "td_block_7";
block_td_uid_9_5d28f09550dae.post_count = "6";
block_td_uid_9_5d28f09550dae.found_posts = "46418";
block_td_uid_9_5d28f09550dae.header_color = "";
block_td_uid_9_5d28f09550dae.ajax_pagination_infinite_stop = "";
block_td_uid_9_5d28f09550dae.max_num_pages = "7737";
tdBlocksArray.push(block_td_uid_9_5d28f09550dae);
</script><div class="td-block-title-wrap"><h4 class="td-block-title"><span class="td-pulldown-size">Latest News</span></h4></div><div id=td_uid_9_5d28f09550dae class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.bjpenn.com/mma-news/ufc/chael-sonnen-praises-ben-askren-for-how-hes-handled-ufc-239-ko-loss/" rel="bookmark" class="td-image-wrap" title="Chael Sonnen praises Ben Askren for how he&#8217;s handled UFC 239 KO loss"><img width="100" height="70" class="entry-thumb" src="https://www.bjpenn.com/wp-content/uploads/Ben-Askren-1-100x70.png" srcset="https://www.bjpenn.com/wp-content/uploads/Ben-Askren-1-100x70.png 100w, https://www.bjpenn.com/wp-content/uploads/Ben-Askren-1-218x150.png 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Ben Askren" title="Chael Sonnen praises Ben Askren for how he&#8217;s handled UFC 239 KO loss"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.bjpenn.com/mma-news/ufc/chael-sonnen-praises-ben-askren-for-how-hes-handled-ufc-239-ko-loss/" rel="bookmark" title="Chael Sonnen praises Ben Askren for how he&#8217;s handled UFC 239 KO loss">Chael Sonnen praises Ben Askren for how he&#8217;s handled UFC 239...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-07-12T12:41:35+00:00" >July 12, 2019</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.bjpenn.com/mma-news/ufc/anthony-smith-goes-off-on-light-heavyweight-rival-corey-anderson/" rel="bookmark" class="td-image-wrap" title="Anthony Smith goes off on light heavyweight rival Corey Anderson"><img width="100" height="70" class="entry-thumb" src="https://www.bjpenn.com/wp-content/uploads/Corey-Anderson-Anthony-Smith-100x70.jpg" srcset="https://www.bjpenn.com/wp-content/uploads/Corey-Anderson-Anthony-Smith-100x70.jpg 100w, https://www.bjpenn.com/wp-content/uploads/Corey-Anderson-Anthony-Smith-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Corey Anderson, Anthony Smith" title="Anthony Smith goes off on light heavyweight rival Corey Anderson"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.bjpenn.com/mma-news/ufc/anthony-smith-goes-off-on-light-heavyweight-rival-corey-anderson/" rel="bookmark" title="Anthony Smith goes off on light heavyweight rival Corey Anderson">Anthony Smith goes off on light heavyweight rival Corey Anderson</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-07-12T12:36:11+00:00" >July 12, 2019</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.bjpenn.com/mma-news/ufc/chad-mendes-reminisces-on-fight-with-conor-mcgregor/" rel="bookmark" class="td-image-wrap" title="Chad Mendes reminisces on fight with Conor McGregor"><img width="100" height="70" class="entry-thumb" src="https://www.bjpenn.com/wp-content/uploads/Conor-McGregor-Chad-Mendes-100x70.png" srcset="https://www.bjpenn.com/wp-content/uploads/Conor-McGregor-Chad-Mendes-100x70.png 100w, https://www.bjpenn.com/wp-content/uploads/Conor-McGregor-Chad-Mendes-218x150.png 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Conor McGregor, Chad Mendes" title="Chad Mendes reminisces on fight with Conor McGregor"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.bjpenn.com/mma-news/ufc/chad-mendes-reminisces-on-fight-with-conor-mcgregor/" rel="bookmark" title="Chad Mendes reminisces on fight with Conor McGregor">Chad Mendes reminisces on fight with Conor McGregor</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-07-12T11:58:28+00:00" >July 12, 2019</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.bjpenn.com/mma-news/ufc/betting-odds-released-for-potential-conor-mcgregor-vs-jorge-masvidal-fight/" rel="bookmark" class="td-image-wrap" title="Betting odds released for potential Conor McGregor vs. Jorge Masvidal fight"><img width="100" height="70" class="entry-thumb" src="https://www.bjpenn.com/wp-content/uploads/Jorge-Masvidal-Conor-McGregor-100x70.jpg" srcset="https://www.bjpenn.com/wp-content/uploads/Jorge-Masvidal-Conor-McGregor-100x70.jpg 100w, https://www.bjpenn.com/wp-content/uploads/Jorge-Masvidal-Conor-McGregor-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Jorge Masvidal, Conor McGregor" title="Betting odds released for potential Conor McGregor vs. Jorge Masvidal fight"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.bjpenn.com/mma-news/ufc/betting-odds-released-for-potential-conor-mcgregor-vs-jorge-masvidal-fight/" rel="bookmark" title="Betting odds released for potential Conor McGregor vs. Jorge Masvidal fight">Betting odds released for potential Conor McGregor vs. Jorge Masvidal fight</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-07-12T11:11:33+00:00" >July 12, 2019</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.bjpenn.com/mma-news/ufc/anderson-silva-says-his-son-will-be-a-better-fighter-than-him/" rel="bookmark" class="td-image-wrap" title="Anderson Silva says his son will be a better fighter than him"><img width="100" height="70" class="entry-thumb" src="https://www.bjpenn.com/wp-content/uploads/Anderson-Silva-100x70.jpg" srcset="https://www.bjpenn.com/wp-content/uploads/Anderson-Silva-100x70.jpg 100w, https://www.bjpenn.com/wp-content/uploads/Anderson-Silva-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Anderson Silva" title="Anderson Silva says his son will be a better fighter than him"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.bjpenn.com/mma-news/ufc/anderson-silva-says-his-son-will-be-a-better-fighter-than-him/" rel="bookmark" title="Anderson Silva says his son will be a better fighter than him">Anderson Silva says his son will be a better fighter than...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-07-12T09:28:55+00:00" >July 12, 2019</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.bjpenn.com/mma-news/ufc/coach-holly-holm-will-recover-from-head-kick-ko-unlike-ronda-rousey/" rel="bookmark" class="td-image-wrap" title="Coach: Holly Holm will recover from head kick KO, unlike Ronda Rousey"><img width="100" height="70" class="entry-thumb" src="https://www.bjpenn.com/wp-content/uploads/Holly-Holm-100x70.png" srcset="https://www.bjpenn.com/wp-content/uploads/Holly-Holm-100x70.png 100w, https://www.bjpenn.com/wp-content/uploads/Holly-Holm-218x150.png 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Holly Holm" title="Coach: Holly Holm will recover from head kick KO, unlike Ronda Rousey"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.bjpenn.com/mma-news/ufc/coach-holly-holm-will-recover-from-head-kick-ko-unlike-ronda-rousey/" rel="bookmark" title="Coach: Holly Holm will recover from head kick KO, unlike Ronda Rousey">Coach: Holly Holm will recover from head kick KO, unlike Ronda...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-07-12T09:21:22+00:00" >July 12, 2019</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 --></div><div class="td-load-more-wrap"><a href="#" class="td_ajax_load_more td_ajax_load_more_js" id="next-page-td_uid_9_5d28f09550dae" data-td_block_id="td_uid_9_5d28f09550dae">Load more<i class="td-icon-font td-icon-menu-down"></i></a></div></div> <!-- ./block -->                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->

<!-- Instagram -->




	<!-- Footer -->
	<div class="td-footer-wrapper td-container-wrap td-footer-template-3 ">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
                		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span4">
                <div class="td-footer-info"><div class="footer-logo-wrap"><a href="https://www.bjpenn.com/"><img class="td-retina-data" src="https://www.bjpenn.com/wp-content/uploads/bj_penn_logo_300x74.png" data-retina="https://www.bjpenn.com/wp-content/uploads/bj_penn_logo_600x148.png" alt="bj penn logo" title="BJPENN.COM" width="300" /></a></div><div class="footer-text-wrap">BJPENN.COM is your premier source for all MMA News. We serve you with the latest breaking news, exclusive fighter interviews, videos and more. It is also the home of 2X UFC Hall of Fame Champion. BJ "The Prodigy" Penn. After a decade of on-line operation BJP has evolved into the most reliable destination for all of your MMA needs.<div class="footer-email-wrap">Contact us: <a href="mailto:contact@bjpenn.com">contact@bjpenn.com</a></div></div><div class="footer-social-wrap td-social-style-2">
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/bjpenn/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/bjpenn/" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/bjpenndotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/bjpenndotcom" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span></div></div>            </div>

            <div class="td-pb-span4">
                <aside class="td_block_template_11 widget widget_nav_menu"><h4 class="td-block-title"><span>Fighter Profiles</span></h4><div class="menu-fighter-profile-menu-container"><ul id="menu-fighter-profile-menu" class="menu"><li id="menu-item-270866" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-270866"><a href="https://www.bjpenn.com/fighter/jorge-masvidal/">Jorge Masvidal Fighter Profile</a></li>
<li id="menu-item-270867" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-270867"><a href="https://www.bjpenn.com/fighter/nate-diaz/">Nate Diaz Fighter Profile</a></li>
<li id="menu-item-270870" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-270870"><a href="https://www.bjpenn.com/fighter/cris-cyborg/">Cris Cyborg Fighter Profile</a></li>
<li id="menu-item-270869" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-270869"><a href="https://www.bjpenn.com/fighter/conor-mcgregor/">Conor McGregor Fighter Profile</a></li>
<li id="menu-item-270871" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-270871"><a href="https://www.bjpenn.com/fighter/ronda-rousey/">Ronda Rousey Fighter Profile</a></li>
<li id="menu-item-270872" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-270872"><a href="https://www.bjpenn.com/fighter/frankie-edgar/">Frankie Edgar Fighter Profile</a></li>
<li id="menu-item-270868" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-270868"><a href="https://www.bjpenn.com/fighter/georges-st-pierre/">Georges St. Pierre Fighter Profile</a></li>
</ul></div></aside>            </div>

            <div class="td-pb-span4">
                <aside class="td_block_template_11 widget widget_nav_menu"><h4 class="td-block-title"><span>MMA News</span></h4><div class="menu-fighter-category-menu-container"><ul id="menu-fighter-category-menu" class="menu"><li id="menu-item-270859" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-normal-menu menu-item-270859"><a href="https://www.bjpenn.com/mma-news/cris-cyborg-justino/">Cris Cyborg News</a></li>
<li id="menu-item-270860" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-270860"><a href="https://www.bjpenn.com/mma-news/nate-diaz/">Nate Diaz News</a></li>
<li id="menu-item-270861" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-270861"><a href="https://www.bjpenn.com/mma-news/jon-jones/">Jon Jones News</a></li>
<li id="menu-item-270862" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-270862"><a href="https://www.bjpenn.com/mma-news/conor-mcgregor/">Conor McGregor News</a></li>
<li id="menu-item-270863" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-270863"><a href="https://www.bjpenn.com/mma-news/georges-st-pierre/">Georges St. Pierre News</a></li>
<li id="menu-item-270864" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-270864"><a href="https://www.bjpenn.com/mma-news/jorge-masvidal/">Jorge Masvidal News</a></li>
<li id="menu-item-270865" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-270865"><a href="https://www.bjpenn.com/mma-news/bj-penn/">BJ Penn News</a></li>
</ul></div></aside>            </div>
        </div>
    </div>
</div>
	<!-- Sub Footer -->
	    <div class="td-sub-footer-container td-container-wrap ">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span td-sub-footer-menu">
                                    </div>

                <div class="td-pb-span td-sub-footer-copy">
                    &copy; 2019 BJ Penn Enterprises <a class="privacy-policy-link" href="https://www.bjpenn.com/privacy-policy/">Privacy Policy</a>                </div>
            </div>
        </div>
    </div>


</div><!--close td-outer-wrap-->



    <!--

        Theme: Newspaper by tagDiv.com 2017
        Version: 9.1 (rara)
        Deploy mode: deploy
        Speed booster: v4.9.3

        uid: 5d28f0956b370
    -->

    
<!-- Custom css form theme panel -->
<style type="text/css" media="screen">
/* custom css theme panel */
.td_block_template_11.widget.widget_media_image {
    display:flex;
    justify-content:space-around;
}

/* Author Box */
.author-box-wrap .avatar {
    border-radius: 10px;
}
.author-box-wrap {
    border: none;
    padding: 0;
    margin-bottom: 5px;
}

.td-author-description
{
 display: none; 
}


</style>

<script type='text/javascript' src='https://www.bjpenn.com/wp-content/themes/Newspaper/js/tagdiv_theme.min.js?ver=9.1'></script>
<script type='text/javascript' src='https://www.bjpenn.com/wp-includes/js/comment-reply.min.js?ver=5.2.2'></script>
<script type='text/javascript' src='https://www.bjpenn.com/wp-includes/js/wp-embed.min.js?ver=5.2.2'></script>

<!-- JS generated by theme -->

<script>
    

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://www.bjpenn.com/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://www.bjpenn.com/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>


<!-- Header style compiled by theme -->

<style>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</style>

<!--<script type="text/javascript"> var infolinks_pid = 3185176; var infolinks_wsid = 0; </script> <script type="text/javascript" src="//resources.infolinks.com/js/infolinks_main.js"></script>-->
</body>
</html>
<!-- Dynamic page generated in 0.298 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2019-07-12 13:41:57 -->

<!-- super cache -->